PyQt5 설치시 pyqtwebengine 관련 오류

PyQt5 설치시 우선 cmd 또는 아나콘다프롬프트를 관리자 권한으로 실행시켜야 한다. (매우 중요!!)
관리자 권한으로 실행시키지 않으면 권한부족으로 설치 실패가 뜬다.

그리고 PyQt5 설치시 위 이미지와 같이 pyqtwebengine<5.13 , pyqt5<5.13 뭐 이런 에러가 뜬다.

이 에러를 해결하기 위해서는
pyqtwebengine 과 pyqt5를 다른 버전으로 설치해야 한다.

위 이미지에 나와있는데로 5.13 버전보다 낮은 버전을 설치해야 하니까 5.12.0 정도로 일단 각각 설치해본다.

설치 명령어는
pip install pyqtwebengine==5.12.0
pip install pyqt5==5.12.0
이 되겠고 이를 cmd(관리자권한)에서 실행해도 무관하지만, 아나콘다 프롬프트(관리자권한)으로 하는 것이 좋다고 한다.

각각 해보면 그런버전이 없다고 하면서 가능한 버전들을 설명해준다.
pyqtwebengine은 5.12.1 버전으로 설치하면 되고
pyqt5는 5.12.3 버전으로 설치하면 될 것 같았다.

그래서 설치했더니 에러는 없어졌다.

아, 참고로 잘못깔았을때 언인스톨하려면
pip uninstall pyqt5 이런식으로 하면 된다.

사람의 생각을 대신해 주는 서비스는 언제 나올까?

    이미지 맵

    Engineering/코딩 다른 글

    댓글 0

    *

    *

    이전 글

    다음 글