[파이썬]matplotlib 써보기 참 힘들다

처음에 파이썬을 설치할 때 path관련 체크박스에 체크를 하지 않아서인지,
파이썬의 설치경로는 C:\Users\나\AppData\Local\Programs\Python\Python38 또는 C:\Users\나\AppData\Local\Programs\Python\Python39가 되어버렸고, 이 때문에 수많은 문제들이 발생하고 있다. 

당분간은 '잘못 설치했을 때를 대비한 훈련'삼아 이대로 써봐야 하겠지만, 다시한번 파이썬을 설치한다면 path관련 체크에 체크를 반드시 해야 할 것이다.

matplotlib를 쓰기 위해서는 파이참에서 openseespy패키지를 설치해야 하는데 현재(2021년 2월)는 코드에 from openseespy.opensees import * 라고 넣어보니 파이썬 3.8에서 지원한다고 파이썬 3.9에서는 import가 되지 않았다.

그래서 파이썬 3.8을 다시 설치해야 되나 했는데, 언제 깔았는지 C:\Users\나\AppData\Local\Programs\Python\Python38 에 파이썬 3.8이 설치되어 있었다.

여기에서 기존환경에 인터프리터를 파이썬 3.8 실행파일을 등록시키면 된다. 그리고 확인.

여기에 openseespy를 검색해서 그 패키지를 설치하면 된다.

사람의 생각을 대신해 주는 서비스는 언제 나올까?

    이미지 맵

    배우자! IT/Web, App 다른 글

    댓글 0

    *

    *

    이전 글

    다음 글